Delivery disruption - Google Cloud Outage

Incident Report for Joe And The Juice status page

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:34 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 13, 2025 - 08:33 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 13, 2025 - 06:39 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 22:21 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 20:30 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 20:20 CEST

Monitoring

We are seeing delivery disruptions due to global cloud outages.
Posted Jun 12, 2025 - 20:00 CEST
This incident affected: Customer Experience (3rd Party Delivery).