Terminal Issues - DK / NO

Incident Report for Joe And The Juice status page

Resolved

This incident has been resolved.
Posted Jul 19, 2025 - 22:47 CEST

Update

Transactions are now going through if repeated.
Posted Jul 19, 2025 - 21:56 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 19, 2025 - 19:30 CEST

Update

We are continuing to monitor for any further issues.
Posted Jul 19, 2025 - 19:20 CEST

Monitoring

We are seeing larger outage on payment terminals across all companies in Denmark & Norway. It seems to be an underlying issue with Nets.
Posted Jul 19, 2025 - 19:10 CEST
This incident affected: POS.